Can't access Tasting Note in Rum-X2 (fixed)

Not all Tasting Notes are displayed in the new beta app if I look into my tasting history. Some of the tastings I did with the rum-x app can’t be accessed even if I publish them again with the old one. Just tried it with my notes for RX1441

I can see it though

If you want to use both apps in parallel (and add tastings or bottles to both) you need to actively synchronize your data.

To do this, go to the Xtend tab in the other app and perform a “pull to refresh”. This will pull the current data and refresh the local cache.

This is a temporary solution as long as both apps still exist in parallel.

I don’t use them in parallel. I wanted to retaste the Rum above and wasn’t able to access the old tasting note in x2. I’m supposed to create a brand new one.

I can see my tasting note in both apps, too. But I can’t retaste the same note.

Currently, if you use both apps in parallel, you have to manually trigger a synchronization if you want to update the data and continue editing on the other version. This can be done in both versions in the Xtend view with a pull to refresh. In the future, I will implement a mechanism that automatically detects that data has been changed from another device and then does the refresh automatically.

1 Like

The issue is not using both apps, but accessing Tasting Notes I’ve once made with the old one.

This was a recurring problem. Sometimes it helped to retaste a old tasting note with the old app and than it became available in the new app - but e.g. for the IdR Fiji 2001 I wasn’t able to access the tasting notes I created with old app at all, only creating a new note was possible.

1 Like

Thanks for the clarification, Lukas. Is the behavior still occurring? I optimized the data model some time ago and this should have eliminated the behavior.

1 Like

The specific tasting note of the idr fiji is accessible now. I’ll try various old tasting notes later on.

1 Like

I don’t know if it’s the same issue I (still) have over here. Tasting notes usually show up the latest after refreshing both apps several times (although I would prefer automagic updates).
My actual issue is that the database differs by 1 bottle in the old app and the new (1 is missing in the new). I don’t know if the number is simply wrong in one of the apps since I couldn’t find which bottle is missing so far due to the large arsenal I have :innocent:


Thanks for pointing that out, Chris! I just investigated this: The new app could not yet read Rums that were created a long time ago (and still followed a different data schema). I have now corrected the entries and after a pull to refresh everything should be in sync again. :slight_smile:

1 Like

Confirmed. Everything is in sync now!

1 Like

@lukasdrinkinghabits Is the problem now also solved for you? :raised_hands:

That’s a nice way of phrasing it :clap:t3::joy:

1 Like

Yes, I can access all tasting notes now.

But I list a significant number of likes. It seems like some rums were tilteda e.g. my tasting note for the RA WIRD 2000

1 Like

Excellent, thank you for your quick feedback.

Technically, there were several tastings by you of the same rum before the correction. I have now merged these duplicates. In the process, a few likes may have been lost (from the deleted duplicates). I am sure that the likes will come back quickly… :smirk::tumbler_glass:

Merry Christmas! :christmas_tree:

1 Like

Thanks and merry christmas :star_struck:

1 Like